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Echo and Reverberation 

1 Introduction 
The MATLAB package includes a high-level technical computing language and an 
interactive environment for algorithm development, data visualization, data analysis, and 
numeric computation. It is possible to prototype and test mathematical algorithms and 
model real-world systems much faster than with other languages, such as C/C++. This 
has led to MATLAB being adopted by a large number of engineering companies across 
the world. The fields covered by these companies include communications, automotive 
engineering, aerospace and defence, electronics and semiconductors, financial services, 
and medical applications. To support this wide variety of applications, the core MATLAB 
software can be extended using a wide variety of additional “tool boxes”. 
 
In addition to the tool boxes, MATLAB can also be augmented by the Simulink package. 
From the MathWorks website: 
 

“Simulink® is an environment for multidomain simulation and Model-Based 
Design for dynamic and embedded systems. It provides an interactive graphical 
environment and a customizable set of block libraries that let you design, 
simulate, implement, and test a variety of time-varying systems, including 
communications, controls, signal processing, video processing, and image 
processing.” 

 
What this means is that Simulink can be used to quickly put together prototypes and 
models of systems using a graphical user interface. Systems can be built by connecting 
together different blocks. These blocks can be selected from pre-defined “block sets” for 
a particular application (e.g. communications, image processing), or can be defined by 
the user. User defined blocks can be created by specifying the mathematical operations 
that are carried out on the block inputs. 
 
This experiment focuses on the Digital Signal Processing (DSP) application area. Echo 
and Reverberation are two of the simplest applications of DSP. This laboratory shows 
how models of Echo and Reverberation can be designed using MATLAB and Simulink, and 
run them in real-time on the Texas Instruments C6000 DSPs. The C6000 family of DSPs 
are widely used in many real-world products. The C6000 family covers a wide range of 
different chips with different clock speeds and power requirements. Example applications 
for two types of C6000 chips are shown in Table 1. 
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Table 1: Examples of C6000 applications, taken from the Texas Instruments 
website.  

Examples of 'C62x Applications: Examples of 'C67x Applications: 
3G Wireless base stations Wireless local loop 
Pooled modems Beam forming base stations 
Cable modems Virtual reality 3-D graphics 
Remote Access Servers (RAS) Speech Recognition 
Digital Subscriber Loop (xDSL) systems Radar/Sonar 
High-performance telephony Precision instrumentation 
Multi-media systems Medical imaging 
Multi-peripheral applications Industrial control 
Wireless PDAs Biometric identification 
VoIP Applications Network camera 
 

1.1 Objectives  
 

► Learn about the differences between echo and reverberation. 

► Learn about Matlab Simulink and modify an existing Simulink model. 

► Design models of Echo and Reverberation for the Texas Instruments C6000 

family of DSP devices using MATLAB® and Simulink®. 

► Run the model in real-time on the Texas Instruments C6713 DSK. 

 

1.2 Introduction to Echo and Reverberation 
Reverberation and echo both occur because the listener hears two or more versions of 
the same sound, where each version arrives at a slightly different time instant. 
 

  
Figure 1: (Left) Illustration of basic principle of echo. (Right) Diagram of basic 

system representing echo over a single path.  
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1.2.1 Echo 
Echo is audible because the speed of sound is relatively slow, about 400 meters per 
second. If we consider only one echo path (as shown in Figure 1), then an echo can be 
simulated using the following equation: 
 

Output = Input + Delayed Input × Gain 
 
Where Gain < 1, due to losses in the echo path. 
 
A real room will have multiple echo paths, as illustrated in Figure 2. The key point to 
note is that the echo is derived solely from the input. 
 

 
Figure 2: Basic block diagram representing multiple echo paths.  

 

1.2.2 Reverberation 
Reverberation is very similar to echo, except that the additional sound sources have 
been processed in some way, e.g. where the extra sound sources are amplified versions 
of the original sound source, as shown in Figure 3.  
 

 
Figure 3: Illustration of reverberation.  
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Figure 4: Simplified block diagram representing reverberation.  

 
A real room will have several echo paths. When sound is reflected off a surface there will 
be “colouration”. Certain frequencies will be absorbed and there will be phase changes. 
Therefore, a commercial echo / reverberation unit will contain many different delay 
paths. 
 
 

1.3 Preparation 

1.3.1 Reading Material 
Ensure that you have read the above details on Matlab and Simulink. To familiarise 
yourself with the Matlab working environment, you should watch these tutorial videos: 

• http://goo.gl/GDvj2 
• http://goo.gl/KxSlc 

To get a head start with Simulink, you should watch the following video tutorial: 
• http://goo.gl/m70vv 

You are also strongly advised to read through the introduction to Matlab in sections 1 
and 2 of the “Simulink 7: Getting Started Guide”. In the same guide, section 3 contains 
a useful tutorial that will help you get familiarised with the Simulink interface by building 
a very basic model. 
 

1.3.2 Preparation Questions 
Your preparation should enable you to answer the following questions: 

1. What is the main difference between echo and reverberation? 
2. What are the six steps involved in modelling any system? 
3. What are the key advantages and disadvantages of system prototyping in 

Simulink for DSP processors? 
4. Why does the slow speed of sound mean that echo can be heard? What would 

happen if the speed of sound was much faster? 
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Input   Output+

+

Delayed  Output

Simplified Reverberation

Gain



5 
 

2 Simulation 
We shall start by running the Echo and Reverberation Simulink models. These use .wav 

files as the inputs. 

2.1 Echo using Wave File  

2.1.1 Opening the Echo Simulink Model 
From MATLAB, open EchoUsingWav.mdl   

 
 

Figure 5 – Echo using .wav File 
 
Run the model and listen to the effect of the delay.  

2.1.2 Changing the Delay Time 
Double-click on the “Delay” block and change the “Delay (samples)” to a different value.          

 
 

Figure 6 – Changing the Delay Time 
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Run the model and hear how the effect has changed. Try a few different settings 

between 100 and 20000 “Delay (samples)”. 

2.2 Reverberation using Wave File  

2.2.1 Opening the Reverberation Simulink Model 
From MATLAB, open ReverberationUsingWav.mdl  
 

 
 

Figure 7 – Reverberaton Using .wav File 

2.2.2 Changing the Delay Time 
Double-click on the “Delay” block. Change the “Delay (samples)” to a different value 

then run the model and listen to the effect.          

2.2.3 Changing the Gain 
Double-click on the “Gain” block. Change the “Gain” to 0.95 then run the model. Listen 

to the effect. 

 
 

Figure 8 – Changing the Reverberation Gain 
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2.2.4 Questions 
 

► Why does Reverberation require a shorter delay time than echo? 

► What effect does the “Gain” block have on the stability of the reverberation 

system?  
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3 Real-Time Model for TI C6713 DSK 
3.1 Texas Instruments C6713 DSK Setup  
 

 
 

Figure 9 – Texas Instruments C6713 DSK Setup 
 
Alternatively, you can use computer loudspeakers.  

Connect the C6713 hardware to a USB port of the computer and turn on the supply to 

the board. 

If the board is powered, then the green LED lights on the board will come on during self-

test. 

3.2  Starting Code Composer Studio  
The stages required to implement Echo and Reverberation are now described. 

3.2.1 Starting Code Composer Studio 
Start Code Composer Studio for C6713 DSK and use Debug -> Connect 
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Figure 10 – Startup Screen for Code Composer Studio (CCS) 

3.2.2 Opening an Existing Model 
Start MATLAB 7.3.0 R2006b 

In the top left hand corner of the MATLAB screen, select File -> Open. 

 
 

Figure 11 – Opening an Existing Model 
 
The following screen will appear. 

 
 

Figure 12 – Selecting an Existing Model 
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Highlight “C6713_Audio_Template” then click on “Open”. 

3.2.3 Viewing the “C6713 Audio Template” 
The “C6713_Audio_Template” is now displayed.  

 
 

Figure 13 – The C6713 DSK Audio Template 

3.2.4 Overview of the Complete Echo Subsystem 
You are now going to implement the Echo Subsystem shown below.  

 

 
 

Figure 14 – The Complete Echo Subsytem 
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3.2.5 Implementing the Echo Subsystem 
Double click on the “Effect 1” subsystem block. An empty model will appear.   

 

 
 

Figure 15 – The Blank “Effect 1” Subsystem 
You will now drag-and-drop some library components onto the model. 

3.2.6 The Simulink Library Browser – Commonly Used Blocks 
Select View -> Library Browser. Expand the “Simulink” section. 

A list of available blocks will appear. We are initially interested in the “Commonly Used 

Blocks”.  

 

 
 
 

Figure 16 – Commonly Used Blocks 
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From “Commonly Used Blocks”, drag-and-drop a ”Gain” block, a “Sum” block and two 

“Data Type Conversion” blocks onto the model. 

3.2.7 The Simulink Library Browser - Discrete 
From the Simulink Library Browser, select “Discrete”. Highlight “Integer Delay” and 

drag-and-drop this block onto the model.  

 
 

Figure 17 – Discrete Blocks 

3.2.8 Setting the Integer Delay Time 
The delay time will be 0.5 seconds. Using a sampling rate of 8000 Hz, this requires 8000 

x 0.5 = 4000 samples. In the equation given in the lecture, this would make N = 4000. 

Double click on the “Integer Delay” block. Change the “Number of delays” field to 4000, 

then click on “OK”. 
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Figure 18 – Setting the Integer Delay Time 

3.2.9 Setting the Output Data Conversion to Single 
We want to set the gain to 0.9. If you multiply an integer value by 0.9, then the value 

0.9 will be rounded-down to zero. Instead, you need to convert the integer value to a 

floating-point value such as “single”, and then convert it back later. Click on “OK”. 

 
 

Figure 19 – Setting the Data Conversion to Single 

3.2.10 Setting the Delay Gain 
We required that 0.9 of the delayed input is added to the normal input. Therefore, set 

the “Gain” to 0.9 then click on “OK”.  
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Figure 20 – Setting the Echo Delay Gain 

3.2.11 Setting the Output Data Conversion to int16 
Double click on the second “Data Type Conversion” block. Set the “Output data type 

mode” to int16. This is compatible with the DAC on the C6713 DSK.  

 
 

Figure 21 – Data Type Conversion to 16-bit Integer 

3.2.12 The Completed Echo Subsystem 
Join the blocks as shown and add a title. 

 
 

Figure 22 – Joining the Blocks 
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3.2.13 Returning to the Parent System 
From the Toolbar, select the “Up Arrow” icon. This returns you to the next higher level.  

 
 

Figure 23 – Returning to the Parent System 

3.3 The Reverberation Subsystem  
The next subsystem to be implemented will be Reverberation. 

3.3.1 Overview of the Completed Reverberation Subsystem 
We are now going to implement the Reverberation System shown below.  

 
 

Figure 24 – Overview of the Reverberation Subsystem 
Note that the reverberation subsystem is very similar to that of echo. We will cut-and-

paste from the Echo Subsystem  

3.3.2 Opening the Effects 2 Subsystem 
From the “C6713 Audio Template” top level, double-click on the “Effect 2” subsystem. 
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Figure 25 – The Blank “Effect 2” Subsystem 

3.3.3 Copying a Block from the Echo Subsystem 
Double click on the “ Effect 1” subsystem. Cut-and-paste a copy of the echo block as 

follows: while left-clicking the mouse, mark the area to be copied. 

 
 

Figure 26 – Outlining the Block to be Copied 
 

Release the left button on the mouse. 
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Figure 27 – Block to be Copied is Marked 
 

From pull-down menu, select Edit -> Copy (or Ctrl + C) 

3.3.4 Blocks Dropped onto Effect 2 Subsystem 
 
Return to the “Effect 2” subsystem and Edit -> Paste (Ctrl + V) into the model. 

 
 

Figure 28 – Blocks Dropped onto Subsystem 

3.3.5 Flipping the Blocks 
 
The blocks are facing the wrong way. Turn them round using Format -> Flip Block. 
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Figure 29 – Flipping the Blocks 

3.3.6 Changing the Integer Delay for Reverberation. 
Because the sound goes round several times with reverberation, a shorter delay time 

can be used. Here the delay time is 0.1 seconds. 

 
 
 

Figure 30 – Delay Time for Reverberation 
 
Set the “Number of delays” to 800 then click on “OK”. 

3.3.7 Completing the Reverberation Subsystem 
Connect the blocks as shown below. Change the title to “Reverberation Subsystem”. 

 
 

Figure 31 – The Completed Reverberation Subsystem 
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3.3.8 Returning to the Parent System 
From the Toolbar, select the “Up Arrow” icon. This returns you to the next higher level.  

 
 

Figure 32 – Returning to the Parent System 

3.4  The Improved Echo Subsystem  
The final subsystem to be implemented will be “Improved Echo”. This is based on the 

“Echo” subsystem, but with several delay paths. 

3.4.1 The Complete Improved Echo Subsystem 
Double click on the “Effect 3” subsystem box. The required components are shown below. 

 
 

Figure 33 – The Improved Echo Subsystem 

3.4.2 Implementing the Improved Echo Subsystem 
You should now have enough knowledge to implement this subsystem block without 

further assistance.  This time you are on your own!  
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3.4.3 Building the Model 
Select Tools -> Real-Time Workshop -> Build Model. 

 
 

Figure 34 – Building the Model 

3.5 Running the Model  

3.5.1 Microphone Straight Through to Loudspeakers 
To check out the microphone and loudspeakers, set the DIP switches on the C6713 DSK 

as follows: 

 
 

Figure 35 – Switch Position 0 
The microphone is fed directly to the loudspeakers without any digital signal processing. 

3.5.2 Switch Position for Echo 
To run the “Echo” subsystem, set the DIP switch to 1. 

 
 

Figure 36 – Switch Position 1 for Echo 
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3.5.3 Switch Position for Reverberation  
To run the “Reverberation” subsystem, set the DIP switch to 2. 
 

 
 

Figure 37 – Switch Position 2 for Reverberation 
 

3.5.4 Switch Position for Improved Echo 
To run the “Improved Echo” subsystem, set the DIP switch to 3. 

 
 

Figure 38 – Switch Position 3 for Improved Echo 
 
 



22 
 

4 Some Things to Try 
4.1 Change the Echo Delay 
Change the value of the “Integer Delay” block for echo. Listen to the effect of using short 
and long delays. Set the delay time to a large value and sing a round such as “Frere 
Jacques” or “Row, Row, Row your Boat”. 

4.2 Change the Amount of Reverberation Gain 
In the “Reverberation Subsystem” block, change the “Gain” from 0.8 to higher and lower 
values. Notice how the system can become unstable if the gain is too large. 

4.3 Modify the Improved Echo Subsystem 
In the “Improved Echo Subsystem”, you may wish to experiment with the number of 
delay elements, the delay times and the amounts of gain. Try to make the echo as 
realistic as possible. 

4.4  Create Your Own Subsystem 
Add your own subsystem block and add your own signal processing. You might want to 
design a subsystem with both echo and reverberation. 
 
 
 

Based on an experiment developed by Texas Instruments Inc, 2007. 
Modified by S. Worrall, 2011. 

 


